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Preface

1. Preface
1.1 Intended Audience

This sites user manual doc is intended to contributor user of FLEXCUBE Direct Banking. Contributor users have
privileges to create new assets and modify existing assets.

1.2 Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

1.3 Access to OFSS Support

https://support.us.oracle.com

1.4 Structure

This document is divided into the following sections: Overview (a brief introduction), Prerequisites, creation of content
creation of pages, ATM branch location configuration steps and configuration for mobile devices.

1.5 Related Information Sources

For more information on Oracle FLEXCUBE Direct Banking Release 12.0.3.0 sites module, refer to the following
documents:

® Oracle FLEXCUBE Direct Banking Sites Developer Guide,

e Oracle FLEXCUBE Direct Banking Sites Installation Guide.doc
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Overview

2. Overview

FLEXCUBE Direct Banking Sites help customers in rapidly rolling out their online banking portals

FLEXCUBE Sites offers a comprehensive extensible content model which will help a bank build
web content (termed “Assets”) effectively and rapidly. The content model helps in building the
following “Asset Types”

e Product Catalogs

e Offers

e Service Catalogs

e FLEXCUBE Direct Banking Widgets

¢ Promotions/Recommendations

e Images

¢ General Content (Articles/Quick Links/Navigation Links etc...)

e ATM and Branch locater
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Pre-Requisites

3. Pre-Requisites

Oracle Webcenter Sites 11.0.8.0.0 should have been installed along with the FC Sites Content
Model.
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Creation of content

Creation of content

As mentioned earlier, FLEXCUBE Direct Banking Sites helps in building content and assemble
pages to rapidly rollout an online portal

This section will demonstrate on how to build content from the various asset model already pre-
configured with FLEXCUBE Direct Banking Sites

Product Creation

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin”

ORACLE" WebhCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password ssssssese

Forgot password?

LOGIN
i/

[C] Remember me

Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

— Contributor Icon
fwadmin  FCWEM_v0.4 @

The contributor interface screen is displayed. This is the main workspace for any content
contributor.




Creation of content

Content

4 Bookmarks (0) + (L] Assignments (0)
= smarttists (0) 4 @ 2 cheouts(0)
3. Click Content > New > New Product. This will display a sequence of screens that will be

required to create a New Product

Enter a name and choose FCWEM-Product from the list of Product Definitions.
Click Continue

The list of attributes that make up the Product Definition is displayed.

-

Product

Name:

*Product Definition: — choose 2 definition — e

-- choose a definition -
FCWEM-Product
FCWEM-ProductApplicationChecklist
FCWEM-ProductApplicationChecklists
FCWEM-ProductApplicationStep

FCWEM-ProductApplicationSteps
FCWEM-ProductComparison
FCWEM-ProductEligibility
FCWEM-ProductExtras
FCWEM-ProductFeatures
FCWEM-ProductOverview

6. Enter values of the attributes one after the other and click the Save icon.
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Creation of content

Product Definition:

“Name: Test Product

*Product Sub Category: ~ K5

Card Branding: v IR5

-

Card Tier: *

*Product Name:

Product Headline:

Product Short Description:

Any sample product can be viewed to see the kind of details that go into the creation of the
product.

7. Click on Search -> Find Product -> Global Bank Max Savings Account

Bl ¢ nv i

Content Metadata

Product Definition: Global Bank Max Savings Account

*Name:  Global Bank Max Savings Account
Template:
Product Sub Category:  Savings Accounts
» *Product Name:  Max Savings Account
Product Headline:  Maximize your savings with our Max Savings Account

Product Short Description:

Global Bank MAX Savings Account

We want you to get the most out of your money and save for your future. The best way to do this is to
open a Global Bank Savings Account.

Take advantage of the following features:

& Debit Card

& Internet Banking

User Manual Oracle FLEXCUBE Direct Banking Sites[] 6



Offers Creation

5. Offers Creation

1. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin"

ORACLE" WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password sessssnee

Forgot password?

LOGIN
s/

[C] Remember me

2. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

Contributor Icon

fwadmin  FCWEM_v0.4 @

The contributor interface screen is displayed. This is the main workspace for any content
contributor

Content Edit

ﬁ Bookmarks (0) RPN " ] ._‘ Assignments (0)

= smarttists (0) 9 & checkouts (0)
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Offers Creation

3. Click Content -> New -> New Offer. This will display a sequence of screens that will be required
to create a New Offer

a_ New Offer x

-

Content Marketing Metadata

offer:

*Name:

*0ffer Sub Category: £4

*Offer Name:

*0ffer Image:

*0ffer Headline:

*0ffer Short Description:

*0ffer Link Text:

Any sample offer can be viewed to see the kind of details that go into the creation of the offer.

4, Click Search -> Find offer -> Visa Platinum Credit Card Movie Buff Offer
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Offers Creation

Offer: Visa Platinum Credit Card Movie Buff Offer - All

*Name: Visa Platinum Credit Card Movie Buff Offer - Al
*0Offer Sub Category: Credit Cards +1
*Offer Name: Visa Platinum Credit Card Movie Buff Offer
*0ffer Image:

Visa Platinum Mavie Buff Credit Card (Offer) - Banner

*0Offer Headline: Visa Platinum Credit Card Movie Buff Offer
*Offer Short Description: Visa Platinum Credit Card Movie Buff Offer
*Offer Link Text: Know More

Offer Information Text:
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Services Catalog Creation

6. Services Catalog Creation

1. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin"

ORACLE" WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password ssssssese

Forgot password?

LOGIN
s/

[C] Remember me

2. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

Contributor Icon

fwadmin FCWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content contributor

Content Edit

ﬁ Bookmarks (0) RPN " ] ._‘ Assignments (0) 9

m

= smarttists (0) 9 & checkouts (0) + 9
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Services Catalog Creation

3. Click Content -> New -> New Service Catalog.
This will display a sequence of screens that will be required to create a New Service Catalog

New Service Cat... x

Content Marketing Metadata

Service Catalog Definition:

*Name:

*Service Sub Category: el

Service Name:

Service Headline:

Service Short Description:

Any sample offer can be viewed to see the kind of details that go into the creation of the offer.

4. Click on Search -> Find Service Catalog -> Wealth Services
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Services Catalog Creation

Bl » nvi

Content Marketing Metadata

Service Catalog Definition: Wealth Services

*Name: Wealth Services

*Service Sub Category: Wealth Management 4
Service Name: Wealth Services
Service Headline: Wealth Services

Service Short Description:

User Manual Oracle FLEXCUBE Direct Banking Sites[] 12



FCDB Widgets

7. FCDB Widgets

1. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin”

ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me

2. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

Contributor Icon

fwadmin  FOWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content
contributor
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Content Edit View

A

FCDB Widgets

ﬁ Bookmarks (0)

5] smartLists (0)

3. Click on Content -> New -> New FCDB Widget.

+ 9

This will display a sequence of screens that will be required to create a New FCDB Widget

New FCDB Widget x

-~ B

m

Content Marketing
FCDB Widget:
*Name:
Template:

*Widget Parent Definition:

*FCDB Widget Name:

*FCDB Widget Description:

Field Device ID:

Field Lang ID:

Field Request ID:

Cinld Cartine THe

Metadata

- choose display style —
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FCDB Widgets

Any sample FCDB Widget can be viewed to see the kind of details that go into the creation of the
offer.

4, Click Search -> Find FCDB Widget -> FCDB Notifications Widget

Bl » nvi

Content Marketing Metadata

FCDB Widget: FCDB-NotificationsWidget

*Name: FCDB-NotificationsWidget
Template: FCWEMTEMPLATES-FCDBNotifications Template
*Widget Parent Definition: FCDB-RPCParentWidget v IS
W
- *FCDB Widget Name: Motifications
*FCDB Widget Description: Notifications
Field Device ID:
Field Lang ID:

Field Request 1D:

7.1 Promotions/Recommendations

1. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin"

ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me
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FCDB Widgets

2. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen Contributor Icon

fwadmin FCWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content
contributor

Content

ﬁ Bookmarks (D) 9 || Assignments (0) 9
JiE| smartLists (0) L " ] -+, Checkouts (0) 9
3. Click Content -> New -> New Recommendation.

This will display a sequence of screens that will be required to create a New Recommendation
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FCDB Widgets

3 Wew Recommen... =~ X

Recommendation

Name + Type } Options + Build + Selection F Sort

*Name: TestReco
Description:
Subtype: (no subtype)
Start Date:
End Date:
Mode: © List

© Recommendation

o pr——

Recommendation: TestReco

* Name Type » Options * Build * Selection » Sort

Recommendation Type: ) Related Items (defined on asset forms)
@ Static Lists (optionally by segment)

™ Dynamic Lists (generated by an element)

User Manual Oracle FLEXCUBE Direct Banking Sites[] 17



FCDB Widgets

Recommendation: TestReco

» Name » Type Options » Build ¢+ Selection FSort

Options: () Bring back children of returned assets.

@ Do not bring back children of returned assets.

Promotions can override this recommendation.

@ Promotions cannot override this recommendation.

@ This recommendation applies to all asset types.

This recornmendation applies to the following asset types:

Attribute Editor -
Blog Asset (o
Blog Asset Definition

Blog Attribute

Blog Author “
Blog Author Category -
Blog Author Category Definition

Blog Author Definition

Blog Category

Blog Category Definition 5

Remove

User Manual Oracle FLEXCUBE Direct Banking Sites[]
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FCDB Widgets

Static Lists:  New Static List: = <Select Segment=

]ﬁ Segment: PERSONAL

Ttem Name In Segment Confidence Out of Segment Confidence

Mo itemns specified

Hint: Drag ttems from the tree or docked search in to the drop zone.:

Static Lists:  If No Segments Apply:

Ttem Name Confidence

Mo itemns specified

Hint: Drag items from the tree or docked search in to the drop zone.:

The drop-zones are content placeholders. Any kind of content created in the previous steps can
be dragged and dropped to this zone

User Manual Oracle FLEXCUBE Direct Banking Sites[] 19



FCDB Widgets

Any sample Recommendation can be viewed to see the kind of details that go into the creation of
the offer.

4. Click Search -> Find Recommendation -> FCWEM-GenY-Recommendation

B 5 | nva

Recommendation: FCWEM-GenY-Recommendation

*Name: FCWEM-GenY-Recommendz
Description: Gen Y Recommendation
Subtype: (no subtype)
Start Date:
M
| End Date:
Mode: © Lst

@ Recommendation

Options: Does not bring back children of returned assets. Change

Promotions cannot override this recommendation.
This recommendation applies to all asset types,

Type: Static Lists

Static Lists: Change

7.2 Images

1. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin"
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FCDB Widgets

ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me

2. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

Contributor Icon

fwadmin FCWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content
contributor

Content

4 Bookmarks (0) 9 (L] Assignments (0) it 9

m

(5| smartLists (0) 0 ¥, Checkouts (0) ¥+ 9

User Manual Oracle FLEXCUBE Direct Banking Sites[] 21



FCDB Widgets

3. Click Content -> New -> New Image.
This will display a sequence of screens that will be required to create a New Image

New Image x

Content Marketing Metadata

Any image for the solution:

*Name:
Template: - choose display style -
*Image Sub Category: N &y

*Image Description:

Image: Browse

Image Alt Text:

Caption for the image:

Image Height:

Any sample Image can be viewed to see the kind of details that go into the creation of the Image.

4. Click Search -> Find Image -> Mobile Services Offer - Thumbnail Image
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FCDB Widgets

Bl 2 nv i

Content Metadata

Any image for the solution: Mobile Services Offer - Thumbnail Image

*Name:  Mobile Services Offer - Thumbnail Image
Template:

*Image Description:

Image:

Image Alt Text:  Mobie Services Offer

Caption for the image:  Mobie Services Offer

7.3 General Content

1. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin”

ORACLE" WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password LTIy

Forgot password?

LOGIN
—

[C] Remember me

2. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

User Manual Oracle FLEXCUBE Direct Banking Sites[] Contributor Icon




fwadmin FCWEM_v0.4

FCDB Widgets

The contributor interface screen is displayed. This is the main workspace for any content

contributor

Content Edit View v
A 3
*
ﬁ Bookmarks (0) ¥ 9 ] Assignments (0) 9 N
= smartLists (0) 4 @ 2 checkouts(0) N )
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FCDB Widgets

3. Click Content -> New -> New Content.
This will display a sequence of screens that will be required to create a New Content

-

Content Marketing Metadata
Announcement:
*Name:
Template: — choose display style —
*Content Sub Category: v IS,
*Content Title:
Headline:

Content URL Link:

Content Short Description:
Any sample Content can be viewed to see the kind of details that go into the creation of the

Image.

4. Click Search -> Find Content -> Product Announcement - Cash Retraction
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FCDB Widgets

Bl © nv i

Content Metadata

Announcement: Product Announcement - Cash Retraction

*Mame:  Product Announcement - Cash Retraction
Template:
Content Sub Category: Announcements
*Content Title:  Cash Retraction Facility
Headline:

Content URL Link: #

Content Short Description: Cash Retraction Facility has been disabled on all Global Bank ATMs

Content Description:

Content Thumbnail:
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Creation of Pages

8. Creation of Pages

Once the content has been created, pages have to be setup.

8.1 Page Creation

1. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin"

ORACLE" WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password LTIy

Forgot password?

LOGIN
)

[C] Remember me

2. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

; Contributor Icon
fwadmin  FCWEM_v0.4 @

The contributor interface screen is displayed. This is the main workspace for any content
contributor
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Content Edit View

L

Creation of Pages

ﬁ Bookmarks (0)

| smarttists (0)

9 ._‘ Assignments (0)

+ 9 ¥ Checkouts (0)

3. Click on Content -> New -> New Page
New Page x
Page
Name:

*Ppage Definition:

— choose a definition —

-- choose a definition -
FCWEMPageDef(2)-BusSeglLP
FCWEMPageDef(3)-BusSegLP
FCWEMPageDef-BusSegLP
FCWEMPageDef-CustSeqgLP
FCWEMPageDef-Home
FCWEMPageDef-ProdCatLP
FCWEMPageDef-ProdLP
FCWEMPageDef-ProdSubCatLP
FW_ArchiveBlogs
FW_AuthorBlogs
FW_RecentBlogs

User Manual Oracle FLEXCUBE Direct Banking Sites[]
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Creation of Pages

FLEXCUBE Sites offers OOTB a set of Page Definitions which can be utilized by the bank to
create new pages. Alternatively, it is very easy for a bank to create their own Page Definitions

In our case, we will choose to create a Business Segment Landing Page. Choose
FCWEMPageDef-BusSegLP

flew Page * x
Content Metadata

Business Segment Landing Page Definition:

*Name:

Template: FCWEMTEMPLATES-BusSeglayout-1

. *Page Title:

B *Casual Visitor Page Attribute:

Navigation Links:

FCDB Widget:
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Creation of Pages

4, Enter the set of attributes as mentioned and click on the "Save" icon.
Note: You can also choose the "Web" mode to have a visual representation of the page as you
continue editing it
Any sample Page can be viewed to see the kind of details that go into the creation of the Image.
5. Click on Search -> Find Page -> Personal Banking

_

Bl ¢ nv

|

Content Metadata

Business Segment Landing Page Definition: Personal Banking

*Name:

Template:

*page Title:

*Casual Visitor Page Attribute:

Navigation Links:

FCDB Widget:

Showcase Recommendations:

Personal Banking

FCWEMTEMPLATES-BusSeglayout-1

Personal

PERSONAL

Contact Us - Navigation Link

Security Center - Navigation Link

Ways to Bank - Navigation Link

Logout - Navigation Link

FCDB-LoginWWidget

FCWEM-PersonalShowCase-Recommendation
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Creation of Pages

6. At any time, to preview your changes, click View -> Preview in New Window.
A new browser window will open up which shows the changes of your page.
1351275817142 - e d

gé,% ContactUs Security Center Ways to Bank Logout
GLOBAL Bank
Corporate Weath About s

Get upto 5% cash-back with our new °
Visa Gold Credit Card

Login

Internet Banking

AN

Cashback Credit Card Interational Debit Card 2 Wheeler Loan

Enjoy upto Rs 2500 Bonus Reward Earn cashback and rewards on all Your wait for a Bike ends here. Your
pointson your first spent with Futura purchases along with entertainment. ridemade easy for just Rs 50 per day
Credit Card. Apply online in just 2 steps. Business Banking
Security Online
Apply Apply Apply New User? Get UserlD
Forgot Password?
Wlm Commenle R L - Dislladin Dacrd Opinion Poll v
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New ATM or Branch locater configuration steps

9. New ATM or Branch locater configuration steps

9.1 Locater Asset

Locater asset family provides the functionality to the user to locate ATM or Branch on map. To
mark a new location on you need to first create a Locater Parent which specifies the country in
which ATM is located. All ATM and Branch are located in same country have the same Locater
Parent.

Creating New Locater Parent Assets
1. Login in FlexCube Sites in contributor mode.

2. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin”

ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me

3. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

Contributor Icon

fwadmin  FCWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content contributor
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Content View

New ATM or Branch locater configuration steps

4 Bookmarks (0) + (]

SmartLists (0) + @ -

4. Click Content -> New ->New FCWEM_Locater Parent

L& bl b

Assignments (0)

Checkouts (0)

New cos_user_id

New cos_user_link
MNewr FCDB Widget
New FCDB Widget

New FOWEM Locater

MNew FOWEM Locat...

Newr Fee-Rate
lew Fees-Rates Par.

New History Attribute
News History Definiti...

New Image

New v Locater Parent

+ 9

fwadmin FCWEM_v0.4 n o,,.,.

New Offer

New Offer Parent
MNew Page

New Product

New Product Parent

Mew Promation

New Recommendat:
New Segment
MNew Service Catzlog

New Service Catalo

m

L°

L5

ORA onte d o
New 13 .
New Blog Asset New cos_install
~WEM_v0.4 Site New Blog Author New cos_listed_ent
laced Pages MNew Blog Author C... Mews cos_poll
= Home (Non Authenticated Users) (N Approve »
& D ome (Non Authenticated Users) (Ne pe New Blog Category News cos_rating_fead
(=[] Personal Banking
H [i=] Savings Accounts New Collection MNews cos_rating_rec...
— Access Permissions
) [=] current Accounts Mew Content Mew cos_review_fe
® [F] Loans Bookmark
I Mew Content Parent News cos_review_re
@ [=] cards
® [E] Corporate Mew cos_blab New cos_site
Locats
D oeaier Mew cos_category New cos_st_locator
- [I5] Wealth
[=] Regular Savings Account Mew cos_category_... Mew cos_st_value
[E E’ Home (Segmented Authenticated Use Mew cos_comment MNew cos_topic
[i=] Accounts
(# [=] salary Accounts rageTTIOer FETSOTTaT
i [=] max Savings Account
{8 Unplaced Pages. - *Casual Visitor Page Attribute: PERSOMAL

i.. [i=] AboutlSTestPace 4

Following screen will appear
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New ATM or Branch locater configuration steps

D Yy fwadmn  FvEos |9

ORACLE WebCenter Sites Content

New FCWEM Loc...

FCWEM_v0.4 Site 1

(= [ Placed Pages

=) |i=| Home (Mon Authenticated Users) (Ne. T Marketing Metadata
(=) |i~| Personal Banking
i (=] savings Accounts.
& [ Current Accounts Locater_Country:
@ [ cargs
@ [i=] corporate *Name:
i=| Locater
i=] Weatth Template: - chaose display style — -
i~ | Regular Savings Account et cheoes digly =52 .
(® [i"] Home (Seamented Authenticated Use Country:
B i~ | Accounts
@ [ salary Accounts
‘.. [] Max Savings Account Country Location:
= [ Unplaced Pages o
i~| AboutUSTestPage 4
LR Copy Of Savings Accounts_S5018...
Fill the form according the table
Column Description
Column Name Column Value
Name Name of the asset
Country Country name in which ATM / Branch is located
Country Location This column contains longitude and latitude of geographical

location of country. To get this column value (longitude and
attitude) name of location. You can also put longitude and attitude
direct in given text box.

5. After filling country name and in text box click Search button. Following screen appears
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FCWEM_v0.4 Site g B

=) (i Piaced Pages —— —

&] Home (Non Authenticated Users) (Ne - Marketi Metadat
() [=] Personal Banking

Savings Accounts
Current Accounts
Loans

Cards

Corporate “Name: ‘ MumbaiGoregaonATM b4 |
; Locater
i Wealth Template: |— choose display style -
- [i=] Regular Savings Account
# [1=] Home (Segmented Authenticated Use

Accounts Country: ‘Inda % |
® Salary Accounts
- [77] Max Savings Account Country Location: |22,87944,84,58788| | [Search |
(= (@l Unplaced Pages -
i AboutUSTestPage
i Copy Of Savings Accounts_S5015.

~ 1

T
Map dsts 2013 MapLink - Terms of Use
J

6. To adjust the longitude and latitude on map click on red mark on the map and drag to desired
location.

Jountry Location: |20 593684,78 96288 |[Search |

7. After proving the value of all required field to save the asset and close the tab.

8. Go In the menu bar, select Content > Save & Close.
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Creating New Locater Assets
Click Content -> New ->New FCWEM_Locater

Following window will appear

Mew »
MNew Article
MNew Article Category
Mew Blog Asset
Approve b

Mew Blog Author

Mew Blog Author C...

. A Permissi
- ccess Permissions New Blog Category

Bookrmark
ookmar MNew Collection

MNew Content

Mew Content Parent

Mew Content Query

MNew FCDB Widget MNew Offer

MNew FCDB Widget ... MNew Offer Parent

Mew FCWEM Locater I Mew Page

New FCWRM Lo bloas Product

Mew FCWEM Locater
Mew History Attribute Flew Product Parent
MNew History Definiti.. MNew Product Parent0
New Image New Product0
Mew Image Category Mew Promotion
Mew Image Parent Mew Query

Mew Imagel

Mew Recommendati..

Mew Segment
Mew Service Catalog
New Service Catalo...

Mew Site Visitor

MNew Site Visitor Att...

Mew Site Visitor Def...

MNew Site Visitor Par..

MNew Visitor Attrbute

4

Template:

*Casual Visitor Page Attribute:

*Page Title: Persanal

Navigation Links:

FCWEMTEMPLATES-BusSeglayout-1

PERSONAL

Help - Navigation Link

Security Center - Mavigation Link

Ways to Bank - Navigation Link
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2. After click on FCWEM_ Locater following content form will appear.

o [

Content Marketing Metadata URL
Locater:
*Name:
Tags:
Template: - choose display style —
*Locater_Country: v IS
*Locater Type: ATM
*State:
*City:
*Location:
L [+
*Locater Description: <
_| oland
.“""“."‘1" X U'f“’i"e- Kazskhstan Moﬂgoli‘a
Italy 2
Turkey A A d]
"'aq ¥ Mgham;‘l:a.n Cch South Korea
Libya | EGYPL S Pakistan SN
Arabia a1 e
To fill the contributor form please refer the below table
Column Description
Column Name Column Value
Name Name of the asset
Locater_Country Select the country name from parent asset.
Locater Type Select Locater type from drop down acceptable values is ATM and
Branch.
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Column Name Column Value
State Enter state where ATM/Branch is located.
Location This text box contains the longitude and attitude of geographical

location where ATM/Branch is located. To fill this column value you
can enter longitude and latitude value directly or enter the location
name and click on search batten.

Locater Descriptor  This column contains description of ATM/Branch.

3. To find longitude and latitude of location of ATM/Branch enter the name of location and click on
search button. Following screen will appear. You can adjust longitude and latitude location by
dragging click on red marker on desired location.

City:

Location: 18.156952.73.295701 Search

ru
A= o 48 Rasgyanl

Locater Description:

= Pen Lonavala Bahul
Alibaugh & . : 2
g % - leprlo oBhosari
Chinchwad & © Kharadi
Pune Pat
]
M@ 4
Shnvaﬁvdhan Mahed m
66 V‘{fil Rh
Dapoli )
o= Khed Satara
Asq_rde 04 o Koregat
I a o
SUB292" Chiplun
(43 ol
~aGIGHIE Map dats £2042 Google - Terms of, Use
4, To add the Locater Description click in text box. Following screen will appear. You can format

your content using CKEditor. This description wills we displayed for this ATM/Branch when user
hover mouse over this location on map.
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g Content Marketing Metadata
City:
Location: |1 156952,73 296701
Lt iption: =] Source E W G| e e
« B e BoPFE
€
B I U= X x2 =i ETS
Styles | 8 Normal ... "=\ Fo | N Size *
4
T A- B R
=
Global Bank

ATM Branch Locater

body div

9.3 Configuring default location when page load

To configure default location of map when locater page load follow these steps.

1. Login to contributor interface and open LocateUs page in edit mode.

User Manual Oracle FLEXCUBE Direct Banking Sites[]

39




(@) Oracle WebCenter Sites 11gR1 - Mozilla Firefox

New ATM or Branch locater configuration steps

x| {7 renderlookup

= &
2t -~ o
Ple & |

Ele Edit View History Bookmarks Tooks Help
| £ Oracle WebCenter Stes 1191 | [ Orecle FLEXCUBE Sites - vL.0 « | EElorad

€ | @ 10.184.132.138:6080/cs/wem/fatwire/home

S I

ORACLE" WehCenter Sites

e WebCenter Sites 11gR1
¢ | |B)- Google

fwadmin

B HED @

FCWEM_v0.4 Site
- [l Defaut J
= [ placed pages
=] Accounts
| Salary Accounts

7] Home (Segmented Authenticated Use | T CWEM-Locater:
7] Home (Hon Authenticated Users) (He

Content Metadata URL

= [ Unplaced Pages.
*Name: LocateUs

| Careers

..... i~ | FW_ArchiveBlogs
FWW_AuthorBlogs
| LocateUs Tags:

. [IF] Privacy

i [7] Sharsholders
Template:

... 7] Sitemap

FCWEMTEMPLATES-ATMBranchLocater

*Page Title:

Navigation Links:

O il ] i

HSG for ATH search Error
Content Tree
*Branch Error Msg:

My Work
*Zoom level of Map:

Marketing Tree
[
i L | |

Locate Us

Help - Navigation Link

Security Center - Mavigation Link

‘Ways to Bank - Navigation Link

Locate Us

No ATM found for specified search criteria

No Branch found for specified search criteria

To fill the contributor form of LocateUs page please refer the below table

Column Description

Column Name Column Value

m

Name
map load values)

Page Title
page.

MSG for ATM
search Error available ATM

MSG for Branch
search Error:
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Title of page. Title field also defines the name of link on personal
Message to user when user search criteria did not match to any

Message to user when user search criteria did not match to any
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Column Name Column Value

Map Default Focus  This text box contains the longitude and attitude of geographical

Location location where ATM/Branch is located. To fill this column value you
can enter longitude and latitude value directly or enter the location
name and click on search button.

Zoom level of Map Specifies the zoom level of map.
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10. Viewing Content on Mobile Devices

10.1 Overview

FlexCube Site provides set of devices which allows user to see preview content on different
devices like iPhones, iPads, Android Phone, Android Tablets, and Desktop etc. To view the
content in a particular device follow following steps.

10.2 Viewing Content on Mobile Devices

1. Login in FlexCube Sites in contributor mode.

2. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin”

ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password sesssTeee

Forgot password?

LOGIN
i/

[C] Remember me

3. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

— Contributor Icon
fwadmin  FCWEM_v0.4 @
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4, Open a page to be viewed.

P T Y -

ORACLE" WebCenter Sites Content

a Personal Banking

FCWEM_v0.4 Site 1 4 M B0 v T “

_H Default

(=) & placed pages Content Metadata URL

=] Accounts

*| Salary Accounts . s o .
| Home (Segmented Authenticated Use | BUSINESS Segment Landing Page Definition: Personal Banking

[7~] Gen-Y Page (New)

<) [i] Home (Non Authenticated Users) (Ne *Name: Personal Banking

"| Personal Banking

| Savings Accounts

urrent Accounts Tags:
ards
@ (i) Loans Template:  FCWEMTEMPLATES-BusSeglLayout-1
| Corporate 4
*| Wealth i

(+) @ Unplaced Pages

*Casual Visitor Page Attribute: PERSONAL

*Page Title: Personal

Navigation Links: Help - Navigation Link

Security Center - Navigation Link

Ways to Bank - Navigation Link

< | [ | »
- Locate Us
Content Tree FCDB Widget: FCDB-LoginWidget
My Work

L. S
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5. Select multi-device preview as shown below:

w @ [ 3 i] fwadmin  FCWEM_v0.4 i

ORACLE" WebCenter Sites Content

Personal Banking

FCWEM_v0.4 Site MA ., " @ 7 8 @

(i Defautt g
=) [ placed pages Content Metadata URL ‘ Multi-Device Preview ‘
Arcnunts — - —————
6. On top-right corner select the desired device:

Content

Personal Banking

Multi-Device Preview : :
Nokia Symbian Phones

iPhones

iPads

Android Tablets
Android Phones
Windows Phones

Windows Tablets

BlackBerry10 Phones

Nokia Symbian Phones
Desktop
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So according the size of the device, the content will be displayed either in mobile or desktop view,

as show below:

Kindle Fire HD

10.3 Working Summary:

LSS Android Tablets v

£

GLOBAC Bank

with our Vis

=)
A g™
b < ] Ge
witi > Moy I Credit Cand
e . ‘
-

Lo ey

Nexus 10

The display of the content in either view (mobile, desktop) depends on the width of the device
rendering it. If the width of the device is less than 767px the mobile view is rendered while device

width with greater than 767px gives desktop view.

This is done by using responsive css which gets the window’s resize function and renders

following divs :

<div class="container hidden-phone">

All content under this div will be rendered for desktop view

</div>

<div class="container visible-phone'">

All content under this dev will be rendered for mobile view

</div>
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11. Pretty URL

1. Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials
"fwadmin/xceladmin”

ORACLE" WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password LTIy

Forgot password?

LOGIN
)

[C] Remember me

2. Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on
the Contributor icon on the top-left corner of the screen

Contributor Icon

fwadmin  FCWEM_v0.4 @

The contributor interface screen is displayed. This is the main workspace for any content
contributor
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Content Edit View v
A o]
1%
ﬁ Bookmarks (0) 9 | Assignments (0) ¥ 9
|
= smarttists (0) + 9 & checkouts (0) 9

Select the asset for which you want to change the url. Here we are going to modify url of personal

page
Open Personal page in edit mode. Following screen will appear

Bl » B anmmv G

22

Content Metadata URL
Jse

Business Segment Landing Page Definition: Personal Banking

Ne

URL:

o

Host: http://10.184.132.138:6080/ cs/fowem

Device Group: Desktop

o

Template:  FCWEMTEMPLATES-BusSeglayout-1

o

o

Wrapper: FW_BlogWrapper

Action Auto Generated Status Info
Change Status | Delete Mo @ URL: /Personal.hitml
200 View Mare

3

I Change Status | Delete Mo @ URL: /Blogs

200 View More
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5. Enter the URL value which you want to for this page. In this example we want to make personal
page as Home in url.

6. So make URL attribute value Home.
7. Select relative(*/”) host value from dropdown.
8. Select Device Group from drop down for which you wants to create pretty url.
9. Select template and Wrapper used for rendering page from drop down and click on add button.
New url for this page is added in the url list. Save asset.
WL ~=roroerkng < .
Bl  » B AMmv §
Content Metadata URL
€
URL:
Ne
Host: /
Device Group: Desktop
Template: FCWEMTEMPLATES-BusSeglLayout-1
Wrapper: FW_BlogWrapper
Action Auto Generated Status Info
Change Status | Delete Mo @ URL: /Personal.html
200 View More
Change Status | Delete Ho @ URL: /Blogs
200 View More
3
Change Status | Delete Ho @ URL: /Home
I 200 View More
10. Preview the page in new window.

Now url is contain page name as Home.
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File Edit View History Bookmarks Tools Help

—
T Qe Siboeddes Ol !M.zxcussssm-vm x +[ a o

(%) 10.180.57.187:8070/ cs/fcwem/Home -)\ B - Google P A ¥
g¥ Help Security Center Ways to Bank Locate Us

GLOBAL Bank
o

Get upto 5% cash-back with our new °
Visa Gold Credit Card

Login

Internet Banking
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